
File Transfer Overview

During a pcAnywhere remote control session, you can transfer files and folders between the    remote PC and the 
host PC.    Using the pcAnywhere File Manager you can:

 Browse folders on both the host and remote PC.
 Select files and folders for transfer.
 Create, delete, or rename files or folders on either PC.
 Compare folders on the host and remote PC.
 Synchronize or clone folders on the host and remote PC.

There are three ways to start a file transfer connection in pcAnywhere:
· Start a remote control connection and choose File Transfer from the remote online toolbar.

· Start a file transfer connection. Starting the connection with file transfer mode automatically brings you to the 
pcAnywhere File Manager after connecting to the host PC.

· Add the transfer commands to an AutoTransfer procedure to automatically send, receive, or synchronize files.

During a session with an Online Service, such as CompuServe, MCI Mail, or an electronic bulletin board service 
(BBS), you can:

 Upload (send) files to the online service.
 Download (receive) files from the online service.

    Online service file transfer commands may vary. You must use the file transfer commands dictated by the online 
service you are calling.



Remote Control Session Management

After connecting, a remote PC controls the activities on the host PC. The remote caller can:

Run programs on the host PC.

    Use pcAnywhere File Manager to send or receive files.
    Chat with the host user by typing a conversation on the computer.
    Use options to help navigate the host screen.

    Online menus are available to both the host and remote user after a session is started. 



Host online menu 

If the host PC is not locked, the host 
user can:

§ end a session

§ initiate a file transfer

§ open a Chat window

Right-click the host icon in the system 
tray to access this menu.

Remote online menu 

 Full Screen:    Displays the host in a full-screen windows on the remote PC. 
When full screen is selected, the remote control menu box is not available. To 
access the online menu, right-click the pcAnywhere session icon. Press 
Alt+Enter to change back to window mode.

 Screen scaling:    Scales the host display down to fit in the remote's window. 
Use this when the host's screen resolution is higher than the remote's. If screen
scaling is not selected, the remote user must scroll to view portions of the host 
screen that are too large to fit in the remote window.

 Online options:    Allows the remote caller to change session options for the 
current session. Changes made are temporary and only affect the active 
session. 

 File transfer:    Display pcAnywhere's File Manager window to allow the 
selection and transfer of files.

 Run AutoTransfer :    Allows the remote caller to run an existing AutoTransfer 
procedure or create a new procedure.

 Transfer clipboard:    Transfers the contents of either PC's clipboard to the other
PC.

 Chat with host:    Allows the host and remote user to communicate by typing a 
conversation in a chat window. Use this feature to 'speak' to the host or remote 
user when there is only one phone line available. 

 Session recording:    Records the session activities to a file for later playback. 

 Save screen:    Captures and saves a screen shot during a session for later 
viewing. 

 Switch to voice:    Suspends the data session and allows a voice conversation 
using the same phone line.

 Send Ctr;+Alt+Del to host:    Sends a Ctrl+Alt+Del command to the host to open
the Windows task box. The remote user can then switch tasks on the Windows 
NT host PC.

 Restart host computer:    Restarts the host PC, providing the host has granted 
the caller the right to do so in the caller's properties.

 End session:    Disconnects the remote control session with the host PC. The 
host returns to the mode that is configured in the host's Settings property page.



Transfer Clipboard

The Windows clipboard contains information that is cut or copied from another application. You can use the 
clipboard to transfer information between applications. During a remote control session you can transfer text or 
graphics contained in the host's clipboard to the remote or the remote's clipboard to the host.



Online Service Overview

During a connection with an online service, a terminal window (different from the main pcAnywhere window) 
displays the terminal screen of the online service. This window also includes a menu bar containing options 
affecting the online session. For example, you can:

    Change the type of terminal emulation or set a file transfer protocol during a session
    Print from the Terminal window
    Edit Terminal window text
    Copy text to the Terminal window
    Paste text to an online service
    Adjust online service hardware settings
    Adjust online service Terminal window display
    Run scripts during an online service session
    End an online service session
    Send [upload] files to the service
    Receive [download] files from the service



File Transfer Protocol Overview

To send (upload) or receive (download) files from an online service you must follow the procedures for sending or 
receiving files required by the online service and pcAnywhere.

Both the online service and your PC must use the same file transfer protocol. pcAnywhere terminal mode offers a 
selection of the most popular file transfer protocols for use with online services. Most online services offer a 
number of different file transfer protocols, so finding a match should not be a problem.

Some online services allow you to register a preferred protocol that is used automatically whenever you download 
a file. Other online services prompt you to select from a list of available file transfer protocols. If you want to 
establish a protocol as the default for this online service, you can add this information to the Settings property 
page in the online service connection item properties sheet. 



Online Options Overview

Online options are available only after a remote control session is started. Both the host and remote user can 
access online options, however there are more options available to the remote user since it is the remote PC that 
connects to and controls and host PC. 

Some online options are pre-configured in Application Options. Changes made to any of these options during a 
remote control session affect only the current session and do not alter the settings configured in the application 
options properties or the remote control connection item properties.



Synchronizing and cloning files

The processes of synchronizing and cloning folders are similar and both product the same final result: host and 
remote folders will be identical to each other. The action taken and the effect upon the folders, however, is very 
different.

Synchronization checks both folders and copies missing files in either folder to make the two folders identical:

·  Files that exist on the host but are missing on the remote are copied to the remote. 

·  Files that exist on the remote but are missing on the host are copied to the host. Files are not deleted in a 
synchronization process.

Cloning checks the files in the source folder (the folder you want to clone) against the files in the destination 
folder. 

·  Files that exist in the source folder but are missing in the destination folder are copied. 

·  Files that exist in the destination folder that are not in the source folder are deleted from the destination folder. 

    Use caution when cloning folders. If you are unsure of which files will be deleted from the destination folder, 
perform a folder compare first. 



Remote Online menu

To open the pcAnywhere online menu click 

 in the title bar.

 



To end an online service connection

To end a session with an online session do one of the following procedures:
 Close the terminal window.
 Use the online service's command to end the session.



To connect to an online service

1 Click Call Online Service on the pcAnywhere action bar.

2 Double-click the online service connection item for the service you want to call.

To display the Online Service button on the action bar: 

1 Choose Application Options from the Tools menu.

2 Click the Button Bars tab.

3 Check Call Online Service and click OK.



To change file transfer protocol during a session 

1 In the terminal window, choose Protocol from the Transfers menu.

2 Select the correct protocol for the transfer.

3 Click OK.



To paste text to the terminal window

1 Select the text that you want to paste.

2 Choose Copy (or Cut) from the Edit menu of the application to copy the selected text to the 
clipboard.

3 Switch to the pcAnywhere terminal window.

4 Choose Paste from the Edit menu.



To print continuously from the terminal window
 Choose Print Online from the Sessions menu.

Terminal window output is sent to your printer until you stop terminal window printing.
To stop terminal window printing

 Choose Print Online from the Sessions menu.
 The Print Online option alternates between starting and stopping the print command.
To print only the current screen from the terminal window

 Select Print Screen from the File menu to print the text currently displayed in the terminal window. 



To download (receive) files from an online service

1 In the terminal window, choose a file for transfer and initiate download by following the online service
instructions.

2 Choose Receive File from the Transfer menu.

The selected file and download folder display in the Select Files For Transfer dialog box.

3 [optional] Change the download folder or edit the filename and click OK.



To upload (send) files to an online service

1 In the terminal window,    initiate upload according to the online service's instructions.

2 Choose Send file from the Transfer menu.

3 Select a file for uploading from the Select Files For Transfer dialog box.

4 [optional] Change the upload folder or edit the filename and click OK.



To set file transfer options during an online service connection

1 In the terminal window, choose Protocol from the Transfers menu.

2 Select the protocol and settings for the transfer in the File Transfer Protocol dialog box.

3 Click OK.



To set online service options

1 Right-click the online service connection item for the online service you want to call.

2 Choose Properties from the drop-down menu.

3 Click the Settings tab.

4 Select the terminal emulation required by the online service.

5 [optional] Choose the file transfer protocol of the online service.

6 Type the phone number of the online service.

7 [optional] Click the Advanced tab.

8 [optional] Select options to customize the terminal emulation.



To adjust terminal emulation options during a session

1 In the terminal window, choose Terminal from the Session menu.

2 Select the preferred terminal emulation options from the Terminal Settings dialog box.



To adjust the terminal window display during a session

1 In the terminal window, choose Display from the Session menu.

2 Select the preferred display options from the Display dialog box.

    Automatic Font Sizing: pcAnywhere selects a font size based upon the size of the terminal window.
    Automatic Scroll Bars: Causes horizontal and vertical scroll bars to appear on the screen.
    Status Line: Causes the status line to appear at the bottom of the screen. This status line contains the 
terminal type, communication port, data rate, parity, and flow control currently used.
3 Click OK to close the dialog box and save the changes.



Online service connection item

The Online Service button on the pcAnywhere action bar is disabled by default. 

To display the Online Service button on the action bar:

1 Choose Application Options from the Tools menu.

2 Click the Button Bars tab.

3 Check Call Online Service and click OK.

To create an Online Service connection item:

1 Click Call Online Service on the pcAnywhere Action Bar.

2 Double-click Add Online Service Item to run the Online Service wizard.

3 Follow the on-screen instructions to complete the wizard.

4 Double-click the new connection item to make a connection.

Note: The online service wizard creates a connection item using pcAnywhere's default settings. To 
view or modify the default settings, right-click the connection item and choose Properties from the 
drop-down menu.

 Click the Help button on any property page for detailed information on the available settings.



Online Service connection item
Double-click to connect to an 
online service.

Right-click to change this item, 
to rename it, or to delete it.



To clone folders
    Cloning folders could result in data loss.    Cloning produces an exact duplicate of the selected folder. 

Files in the destination folder that are not in the source folder, are deleted.
In the File Manager Window:
1 Choose the source folder; the folder you want to duplicate.

2 Choose Clone from the File menu.

3 Confirm that the source and destination folders are correct.

4 Click Yes to begin the cloning process.



To compare folders

The Compare Folders feature looks at both host and remote folders and informs you if they are the 
same. If the folders differ, the files that are different or missing are highlighted in both folders. The 
compare folder function only informs you of the differences; no action is taken.

In the File Manager window:

1 Select the host and remote folders to compare from the list.

2 Choose Compare Folders from the File menu.



To synchronize files and folders

Synchronizing changes both host and remote folders by copying files in both folders to make the two 
folders identical to each other. Synchronizing does not delete files as cloning does. It adds any missing
files to both folders.

In addition to synchronizing folders, you can synchronize selected files. For example, you may want to 
synchronize only *.DOC files. Synchronization on selected files ensures that both host and remote 
contain identical versions of the file.

In the File Manager window:

1 Select the host and remote folders you wish to synchronize.

2 Do one:

· Choose Synchronize from the File menu.

· Click Synchronize on the File Manager action bar.

3 Confirm that both the host and remote folders are correct in the Synchronize Folder dialog box.

4 Click Yes to begin synchronization.

To synchronize selected files in folders:

In the File Manager window:

1 Select the files on the host and remote that you want to synchronize.

2 Do one:

· Choose Synchronize from the File menu.

· Click Synchronize on the File Manager action bar..

3 Click Yes.



To select files and folders

To select a different folder

1 Choose a file container from the drop-down list box.

A list of available folders, files, or drive mappings appears.

2 Do one:

    Click on a folder to select it.
    Double-click on a folder to open it.
To select two or more files or folders in a sequential group

 Click the first file or folder, then press Shift and click the last file or folder in the group.
To select multiple files not in sequence

 Click the first file or folder, then press Ctrl while clicking each of the other files or folders.



To exit File Manager and return to remote control

Do one of the following:

    Click Rem Ctrl in the File Manager action bar.
    Choose Close from the File menu.
The File Manager window closes and you are returned to the remote control session with the host PC.

    NOTE: If a file transfer connection was made by selecting File Transfer from the pcAnywhere Action 
Bar, selecting Close from the File menu ends the session. Click Rem Ctrl in the File Manager action bar 
to return to a remote control session. 



To delete folders or files

In the File Manager window:

1 Select the files or folders you want to delete.

2 Do one:

· Choose Delete from the File menu.

· Right-click the file you want to delete and choose Delete from the drop-down menu.



To copy files or folders

In the File Manager window:

1 Select the file or folder you wish to copy.

2 Do one:

    Choose Copy from the Edit menu
    Right-click the file or folder and choose Copy from the drop-down menu.



Open the pcAnywhere File Manager

Use the pcAnywhere File Manager to transfer files between a remote and a host during a remote 
control session, and to manage folders and files on both host and remote PCs. 

To access the File Manager from the remote:

1 Begin a remote control session.

2 Do one of the following:

    Choose File Transfer from the remote online menu.
    Click file transfer 
 on the remote online toolbar.
To access the File Manager from the host:

1 Begin a remote control session.

2 Right-click the pcAnywhere icon in the System Tray  and choose File Transfer from the 
pcAnywhere menu.

3 Select Controlled by Host from the submenu.



To change file transfer options during a session

Make a remote control connection.

1 Choose File Transfer from the remote's online menu.

2 Choose Options from the Tools menu.

3 Check to enable any of the following options:

· Destination File — select a file overwrite preference from the drop-down list. If you intend to 
overwrite a large number of files, or if you are running an AutoTransfer procedure, you may want to 
choose to overwrite automatically, or overwrite older files only.

· Use Compression — to improve file transfer speed by compressing files during the transfer. Files are
uncompressed to their original state before being written to the destination folder.

· Allow Crash Recovery — to have pcAnywhere continue transferring an interrupted file transfer at the 
point of the interruption. If crash recovery is not enabled, an interrupted file transfer starts at the 
beginning of the file. You should consider using this option when transferring very large files.

· Use SpeedSend  — to have pcAnywhere compare duplicate filenames and transfer only the data 
that is different in the source file.

· Virus Check All Downloaded Files — to allow Norton AntiVirus scan all files for viruses before 
downloading.

· Transfer, Move — to receive a confirmation dialog box before transferring or moving files.

· Synchronize — to receive a confirmation dialog box before synchronizing files.

· Include Subfolders in All Operations — to include subfolders automatically in any file transfer 
command.



The File Manager action bar

Closes the File Manager window and returns to the remote control session.

Transfers the folder or file selected on the remote PC to the selected folder on the host 
PC.

Transfers the folder or file selected on the host PC to the selected folder on the remote 
PC.

Synchronizes the folders selected on the host and remote PC. Synchronization does not 
delete files. Missing files in either folder are copied, resulting in both folder matching 
exactly.

Allows the remote user to run or create a new AutoTransfer procedure or edit an existing 
procedure.

You can add more than one file or folder at a time to a procedure by selecting the files or 
folders from either the remote or host file list and clicking the Add button.



Remote online toolbar

 



File Container drop-down list box

 




